jueves, junio 21, 2007

CINELERRA EN GUTSY 7.10, EL MEJOR EDITOR DE VIDEO (ACTUALIZADO 27 DIC 2007)


Cinelerra actualmente está considerado como sino el mejor, uno de los mejores editores de video del mundo, y como no open source. (PROBADO EN FEISTY Y GUTSY)

Bueno, visto lo visto y los problemas para instalar cinelerra he decidido reunificar mis posts y realizar uno para definitivamente explicar la instalación de cinelerra en UBUNTU GUTSY. Voy a explicar dos metodos, uno compilando y otro desde unos archivos preparados.
Vamos allá:


METODO 1: COMPILACIÓN (basado en http://ubuntuforums.org/showthread.php?t=623589 )
1 Instalamos el paquete subversion mediante el comando:
sudo aptitude install subversion
2 Ahora chequeamos el código fuente de cinelerra mediante el siguiente comando desde el terminal:
svn checkout svn://svn.skolelinux.org/cinelerra/trunk/hvirtual

3 Instalar las dependencias para compilar cinelerra, que no son pocas, mediante el comando:
sudo apt-get install g++ git-core cogito subversion automake libtool nasm x11proto-xf86vidmode-dev libxv-dev libxxf86vm-dev libogg-dev libvorbis-dev libtheora-dev libopenexr-dev libdv-dev libpng12-dev libjpeg62-dev libtiff4-dev libfreetype6-dev libsndfile1-dev uuid-dev libasound2-dev libavutil-dev libmpeg3-dev libavcodec-dev libx264-dev libfaac-dev libmjpegtools-dev fftw3 fftw3-dev liba52-0.7.4-dev liblame-dev libfaad2-dev libesd0-dev libiec61883-dev libavc1394-dev

4 Una vez instalados hay que introducirse en el directorio de cinelerra (cd hvirtual) y ejecutar el comando:
./autogen.sh
Después:
./configure
Después
make
Y por último si no te salen errores:
sudo make install
Ya tenemos cinelerra instalado.
5 Según postean hay que hacer un par de cositas más para que funciones correctamente, hay que reinstalar dos archivos:
Primero los desinstalamos
sudo apt-get --purge remove faad libfaad2-0
Ahora los volvemos a instalar:
sudo apt-get install faad libfaad2-0

Una vez realizado esto deberias pasar a NOTAS COMUNES A LAS INSTALACIONES.

*PD: me gustaría indicar que aunque me comentan que funciona el METODO 1 no lo he probado personalmente, yo instalé el EL METODO 2

METODO 2: DESDE PAQUETES PRECOMPILADOS (METODO PROPIO)

Primero descargamos el siguiente archivo Cinelerra.tar.gz de aquí http://rapidshare.com/files/73194458/Cinelerra.tar.gz.html.
(Son los arhivos del repsoitorio giss, que funcionaban perfectamente antes de la última actualización.)
Lo extraemos bien desde consola (tar -xj...), bien pulsando boton derecho del raton y seleccionando extraer aquí (...más sencillo imposible...).

Instalamos las librerias fftw3 libmjpegtools0c2a libfaac0 libopenexr2c2a, mediante el comando:
sudo aptitude install fftw3 libopenexr2c2a libmjpegtools0c2a libfaac0
Ahora solo nos queda instalar los paquetes extraidos (del archivo Cinelerra.tar.gz), bien mediante gdebi, bien mediante consola. Si los instalais mediante gdebi según cual instaleis primero os dará error y tendreis que instalar otro antes, no obstante creo que sería mejor hacerlo mediante consola, ingresando en el directorio donde tenemos los cuatro archivos “.deb” descomprimidos y instalándolos mediante el comando:
sudo dpkg -i *.*

******************************************** NUEVO - AÑADIDO 27 -12 - 2007 ********************************************************
METODO 3: Desde Repositorios (Documentación extraída de http://cvs.cinelerra.org/getting_cinelerra.php y también probado y funcionando)

1 Trabajar con el repositorio.

Modificar el archivo sources.list de la siguiente forma:
sudo gedit /etc/apt/sources.list
Añadir la siguiente línea al final (copia y pega) y después guarda el archivo
deb http://repository.akirad.net akirad-gutsy main
Conseguir la clave gpg del repositorio. Teclea en un terminal:
wget -q http://repository.akirad.net/dists/akirad.key -O- | sudo apt-key add -
Actualizar la lista de repositorios:
Primero tecleamos: sudo apt-get update
Despues cuando termine: sudo apt-get upgrade

2 Elegir la opcion de nuestro procesador. Estos repositorios tienen varios paquetes disponibles según el procesador y si posees o quieres dar soporte opnegl o no de tal forma que tendremos los siguientes paquetes:
- cinelerra (sin opengl) (para todos los procesadores)
- cinelerra-generic (con opengl) (para todos los procesadores)
- cinelerra-k8 (con opengl) (para procesadores amd)
- cinelerra-k7 (sin opengl) (para procesadores amd)

3 Instalar: Para instalar el que más os guste podeis utilizar bien el gestor de paquetes synaptic, hoy lo voy a explicar con synaptic así que nos vamos a sistema - administración - gestor de paquetes synaptic, metenos la contraseña, le damos a la pestaña de buscar tecleamos cinelerra. Seleccionamos el paquete que más nos convenga e instalamos. Y ya está, según indican en la página estos paquetes vienen ya con el parche del kernel (shmmax to 0x7fffffff) y con soporte de idioma según la instalación base (que más quieres!!!!!!!!!!!)
De todas formas si os indica lo del kernel y no lo teneis en castellano, pues nada nos vamos a las NOTAS COMUNES A LA INSTALACION y ya está.

NOTAS COMUNES A LAS INSTALACIONES. (Excepto Metodo 3)
Una vez realizada una de las dos instalaciones tenemos que efectuar unos pasos adicionales común a ellas:
1- El kernel de GNU/Linex sólo permite 32MB de memoria compartida, insuficiente en su caso para cinelerra, po lo que es más que probable que cuando inicieis el programa te dé este error:
void Mwindow::init_shm0:WARNING:/proc/sys/kernel/shmmax is 0×2000000, which is too low. Before running Cinelerra do the following as root: echo "0×7fffffff" >/proc/sys/kernel/shmmax

2- Así que para arreglarlo en una terminal nos logueamos como root:
sudo su
(metemos nuestra contraseña) y a continuación tipeamos:
echo "0×7fffffff" >/proc/sys/kernel/shmmax
Bueno aquí gracias a Juan (uno de los lectores del blog) he podido comprobar que por el cambio de kernel, puede ser que no funcione y de error este paso, así que simplemente a los que no les funcionen sigan el primer paso al pie de la letra (...es decir, loguearnos como root: sudo su) y ahora tipear el siguiente comando:
sysctl -w kernel.shmmax=2147483647
y solucionado.

3- Para que éste cambio quede de forma permanente hay que retocar el archivo /etc/sysctl.conf de la siguiente manera:
sudo gedit /etc/sysctl.conf
Añadimos al final:
kernel.shmmax=0x7fffffff

4 Por último, lo TRADUCIMOS AL CASTELLANO, porque nos sale en inglés:
Retocamos el siguiente archivo:
sudo gedit /var/lib/locales/supported.d/local
Añadimos la siguiente línea a las que haya antes de en_EN:
es_ES ISO-8859-1
Guardar el fichero y reconfigurar los lenguajes:
sudo dpkg-reconfigure locales
En el menú de Gnome-Administracion-Soporte de Idiomnas seleccionamos
"Español España".

Y ya está tenemos el mejor editor de video de linux y quizás del mundo y como no de código abierto instalado en nuestra máquina.
Un pequeño manual para utilizar cinelerra y no morir en el intento aquí

37 comentarios:

  1. Samsagaz5:58 p. m.

    Buen tutorial, Carlos.

    Lamentablemente en mi Debian Etch me atasco en la castellanización, ya que el directorio /var/lib/locales no existe en mi distro. Y por supuesto el siguiente directorio, supported.d, tampoco.

    He buscado en el resto del sistema pero no encuentro ningún fichero denominado "local".

    ¿Serías tan amable de ayudarme a castellanizar Cinelerra? Gracias de antemano.

    ResponderEliminar
  2. Con debian no me entero mucho, pero lo que he visto por ahí es que el archivo a modificar es el siguiente

    /etc/locale.gen

    Y para generar las locales el comando que he visto es el siguiente:

    /usr/sbin/locale-gen

    ResponderEliminar
  3. Se me olvidaba, creo que después hay que instalarlo con los siguientes comandos:
    export LANG=es_ES.ISO-8859-1

    ResponderEliminar
  4. Hola, a la hora de hacer:
    6.Así que para arreglarlo en una terminal nos logueamos como root:
    sudo su (metemos nuestra contraseña) y a continuación tipeamos: echo "0×7fffffff" >/proc/sys/kernel/shmmax

    Me dice:
    bash: echo: error de escritura: Argumento inválido

    Que estoy haciendo mal?

    ResponderEliminar
  5. Bueno al parecer he encontrado dos maneras de hacerlo, una era esa pero parece que he encontrado otra para los que no pueden hacerlo de esa manera, al parecer es por el cambio del kernel. simplemente tipea:
    sudo su (nos logueamos como root)
    y ahora:
    sysctl -w kernel.shmmax=2147483647
    Ahora si que sí, bueno lo de modificar el archivo sigue igual, voy a modificar el howto, gracias por tus comentarios

    ResponderEliminar
  6. Samsagaz3:21 p. m.

    Hey, muchas gracias, Carlos.

    Todo ha funcionado como la seda. Ya tengo Cinelerra castellanizado. Gracias a ti. ;-)

    Un saludo.

    ResponderEliminar
  7. Joder joder, muchas gracias tío, qué grande! estaba ya como loco buscando cómo instalarlo sin tener que compilarlo yo. Mil gracias por la ayuda.

    Lo del idioma no me ha funcionado pero eso no me crea ningún problema.

    Gracias!

    ResponderEliminar
  8. Anónimo4:22 p. m.

    Exelente guia para instalar cinelerra, uso ubuntu studio 7.10 y no tuve problemas en istalarlo con tu ayuda. Felicitaciones y muchas gracias. Eduardo Aguilar (Buenos Aires Argntina)

    ResponderEliminar
  9. [...]Cinelerra es un editor de video bastante completo, open source para Linux.
    Para instalar cinelerra en nuestro Gutsy con un simple apt-get, hay que seguir los siguientes pasos:[...]

    Muchas gracias! Sencillo y clarito!

    ResponderEliminar
  10. Gracias a todos por vuestros comentarios, seguimos en la brecha. Force Linux

    ResponderEliminar
  11. Anónimo12:02 a. m.

    He usado hasta ahora Final Cut y quiero canbiar a Cinelerra para ver hasta donde da de sí. Ya llevo unos meses con Ubuntu y quiero olvidar el software propietrio.
    De todos modos no consigo quitar el error que mencionas que aparece al instalar cinelerra:
    void Mwindow::init_shm0:WARNING:/proc/sys/kernel/shmmax is 0×2000000, which is too low. Before running Cinelerra do the following as root: echo "0×7fffffff" >/proc/sys/kernel/shmmax

    Pruebo con las dos soluciones que das e imposible.
    Con la primera me dice:
    bash: /proc/sys/kernel/shmmax: Permission denied
    Y con la segunda:
    error: permission denied on key 'kernel.shmmax'
    Estoy trabajando con el Gutsy Gibbon.
    Socorro!!!
    Ah por cierto gracias por tu página
    Un saludo
    Gontzal

    ResponderEliminar
  12. Anónimo, por la salida en el terminal que comentas me parece que estás haciendo algo mal, dices: "Con la primera me dice:
    bash: /proc/sys/kernel/shmmax: "¡¡¡¡¡¡Permission denied!!!!!!!"
    en el bash primero te tienes que loguear como root, si estás en ubuntu la orden es "sudo su" sin comillas claro y tu password, si estás en otra distribución su y tu password. Bien una vez hecho esto introducir en el bash la siguiente orden: echo "0×7fffffff" >/proc/sys/kernel/shmmax (toda la orden porque lo que veo es que solo has puesto lo último. Si te sigue dando error en lugar de esta orden introduce esta otra: sysctl -w kernel.shmmax=2147483647)
    Ahora inicia el cinelerra y aparecerá bien, sin el error. Este paso deberías hacerlo cada vez que reinicies, con lo cual para evitarlo, tienes que editar el archivo sysctl.conf, para lo cual mete en el bash la siguiente orden: sudo gedit /etc/sysctl.conf, y al final del archivo copia y pega en una nueva linea "kernel.shmmax=0x7fffffff" sin comillas claro. Así la próxima vez que reinicies no te saldrá el error.

    ResponderEliminar
  13. Anónimo8:32 p. m.

    Buenas,
    primero gracias por el tutorial.
    Una vez instalado (tras el paso 4), al lanzar cinelerra desde el terminal para ver si me da el error que comentas, obtengo
    cinelerra: error while loading shared libraries: libGL.so.1.2: cannot open shared object file: No such file or directory

    Alguna sugerencia? Esas librerias no están disponibles desde Synaptic...

    Gracias!!!

    ResponderEliminar
  14. yo tengo el mismo problema de la dichosa libreria...

    ResponderEliminar
  15. Bueno al parecer es una librería un poquito rara, supestamente la tendríais que tener instalada. tampoco he encontrado mucha información al respecto pero tendría que venir en el paquete de vuestra controladora gráfica. Supuesto 1: qué controlador gráfico eneis instalado es decir drivers propietarios o libres. Segundo probar si teneis instalado el siguiente paquete: libgl1-mesa-glx, para lo cual:
    sudo aptitude install libgl1-mesa-glx
    Supuestamente este paquete proporciona la dichosa librería.

    Decidme que tal, si os sigue sin funcionar meteros en nautilus con la siguiente dirección y buscad el paquete a ver si lo teneis instalado
    dirección /usr/lib/ ahí teneis que tener el paquete.

    También decidme la gráfica y los controladores que teneis (esto si no os funciona)

    ResponderEliminar
  16. Anónimo11:06 p. m.

    Buenas,
    he encontrado la solución siguendo los pasos en
    http://ubuntuforums.org/showthread.php?t=623589

    A mi me ha funcionado a la primera, suerte!

    ResponderEliminar
  17. Joder!!!

    Al hacer el primer paso (sudo aptitude install subversion) me ha desinstalado (como lo oyes) muchos de los paquetes que venian en el Ubuntu Studio, pero unicamente los de Audio i Video. No es ninguna broma. Me ha desinstalado, por ejemplo el Ardour... Que ha pasado?

    Pues gràcias, suelo andar por el Ubuntu Catalan Team. Por cierto, soy de Castalla (he visto que eres de Alicante...)

    Salut.

    ResponderEliminar
  18. Te puse en la entrada que el METODO 1 , el que has utilizado yo personalmente no lo he probado aunque al final lo haré. Pero de momento no. No te puedo decir más. Por cierto a Castalla subo a menudo ya que uno de mis mejores amigos es de allí. Saludos, por qué no lo instalas con el METODO 2, que ese si lo he probado.?

    ResponderEliminar
  19. Me ha encantado lo bien explicado. Al final a funcionado pero todo se ha instalado bien pero sin arrancar. He tenido que reinstalar sobre lo hecho desde synaptic y después se decide a dejarse ver ;-).
    El problema es la detección del video VHS por Cinelerra en Ubuntu 7.10. Quizás es que no he leido bien las instruciones.
    Conecto con salidad video euroconector a entrada Pinacle DC10 por Super video y sonido entrada a SB! Live... y no pasa nada.
    ¿Alguna ayuda más?
    y Felices Fiestas y la labor, si no fuera por los que sabeis y nos ayudais, no sabríamos por donde ir.
    Gracias,
    Korces

    ResponderEliminar
  20. Korces no te entendido muy bien lo que intentas explicar, al parecer dices que tuvieste que instalar sobre synaptic el que? No se
    ¿Que metodo utilizaste el primero o el segundo?
    Por favor sé más explicito si no no podré ayudarte

    ResponderEliminar
  21. Gracias por la rapidez ;-)
    Marco los pasos:
    1- Puse repositorios en archivo configuración.
    2- Arranqué synaptic e instalé cinelerra.
    3- Desde aplicaciones no salia ni el nombre del programa.
    4- Desinstalé los archivos desde Synaptic.
    5- Encontré tu página (buena por cierto ;-) e instalé por método 1.
    6- aparece nombre en Aplicaciones -> Sonido Video -> Cinelerra ; pero no arranca.
    7- Voy directamente a sinaptic y veo que Cinelerra está pero sin instalar.
    8-Reinstalo desde Synaptic.
    9- Me arranca Cinelera. Tengo conectado el video VHS con salida euroconector y entrada Super video y sonido a SB Live!
    10- No detecta nada Cinelerra. He mirado algo para ver si había opciones de detección y nada,
    11- Miro en "Unidades y soportes extraibles-> cámars -> "editar video cuando se conecte"
    En ese recuadro no me sale ningún enlace como en los otros periféricos.

    uf,uf,ufffff!!! Me cansao, no aguanto tanto como tu detallando (y yo no demasiado bien).

    Eso es lo que hice y eso es lo que me paso cuando al final consigo que funcione Cinelerra.

    Si puedes atudarme será una gran ayuda.
    Saludos,
    Korces

    ResponderEliminar
  22. Vamos a ver, muy buen detalle :-)!!!
    1º el metodo 1 tal y como pone no lo he probado
    2º Desinstala cinelerra, borra los repositorios y bájate los paquetes del enlace que hay e instalalos a mano, tal y como pone el método 2.
    3º Prueba a conectar la cámara, que veo que no es una cámara sino una tarjeta de tv, no e así? ¿Te la reconoce bien? Puedes ver la tv? Si es así en preferencias en cinelerra pestaña grabación selecciona entrada de video: video4linux
    No he grabado nunca desde una tarjeta de tv en cinelerra siempre ha sido desde camara minidv, por lo que no se como más te podría ayudar.
    Antiguamente cuando grababa desde mi tarjeta de tv utilizaba xawtv para capturar en formato avi y despues el propi cinelerra para editar (es otra solución)
    Ya me cuentas como te va... encantado de ayudarte, no dudes en preguntar.
    Un sabio no se le conoce por lo que sabe sino por lo que pregunta.

    ResponderEliminar
  23. Tengo:
    1. Imagen a pasar:
    Video VHS Tochiba (cintas de video)
    Salida euroconctor

    2- Por donde entra imagen:
    Extremo del euroconector con rca video
    (IN en targeta Pinacle DC10 editora de
    video)y para entrada a sonido con
    mini-jach en extremo euroconector.
    3- Cuando arranco Cinelerra, sólo al
    final es que se oiga (mediocre) el
    sonido pero no lo grabo. La imagen de
    las cintas de video no aparecen.

    Un desastre, no se como hacer para que me detecte la imagen y pueda pasar mis videos ciejos grabados de la tele para meterlos en cd o dvd con mi pinacle dc10... snif, snif ;-)

    Gracias otra vez,
    korces

    ResponderEliminar
  24. hola que tal..
    bueno primero que todo gracias Carlos por tu detallada guía, pero he tenido muchisimos problemas y estoy a punto de explotar ha ha ha haaa. ¡BOMMM!.
    luego de esta performans te explico los problemas que también escribí en el foro de ubuntu.

    Me ha pasado algo similar a korces, he instalado de todas las formas y metodos posibles el cinelerra, pero no logro ejecutarlo, y el icono del programa es un acceso a la nada, lo he desintalado he instalado millares de veces por los distintos metodos pero no pasa nada.

    me siento frustrado puesto que hando buscando un buen programa de edición de video PRO, ya que el dinerillo no alcanza para un MAC, he decidido pasarme al lado oscuro y traicionar a win, con su premier... ya que con las cualidades de mi pc no me corria muy bien.
    y por lo que he leido esta es una muy buena alternativa.

    bueno hace un par de días que estoy ocupando ubuntu así que soy un poco lerdo... por favor AYUDA!!!
    XD

    Saludos Grandes

    ResponderEliminar
  25. Amigo Sajax, te comento yo personalmente lo he instalado con el método 2, que es el único que he probado que funciona, al menos a mi, y por lo que me consta a mucha gente más, de todas formas si t vuelves muy loco, decirte que antes de como tu dices ponerle los cuernos a ubuntu decirte que ubuntu no es linux y que existen una infinidad de distribuciones que incluso llevan cinelerra en sus repositorios o mejor aún instalado desde 0. como (ahora se me ocurren knoppix, elive, dynebolic, etc...

    ResponderEliminar
  26. De todas formas añado un nuevo método que también me ha funcionado esta vez desde respositorios, mira a ver si te sirve.
    Saludos

    ResponderEliminar
  27. He tenido que volver a instalar Ubuntu 7.10. He reinstalado Cibelerra con método 3 y sin problemas.
    El "problema" es que Cibelerra me detecte mi sistema arcaico de Video VHS por medio placa Pinacle DC10 con entrada S-VCD...
    ¿Alguien sabe la clave mágica?
    :-)
    Gracias otra vez y Feliz input y output 2007/2008
    Korces

    ResponderEliminar
  28. Me alegro que lo hayas podido al final instalar korces, lo del vhs ahí si que ya no tengo ni idea pero intentaré ayudarte, dejame que investigue a ver que tal, saludos!!!!! y Feliz año

    ResponderEliminar
  29. Carlos,
    Gracias por tu tutorial.
    Al tratar de instalar dedes el Synaptic "Cinelerra" y "Cinelerra-generic" me sale este mensaje:
    E: /var/cache/apt/archives/libmpeg3hv-generic_1%3a2.1.0-1svn20080222akirad1_i386.deb: intentando sobreescribir `/usr/bin/mpeg3cat', que está también en el paquete mpeg3-utils

    ¿Sabes cómo puedo solucionarlo?

    Gracias por tu ayuda.

    ResponderEliminar
  30. Desinstala primero el paquete de conflicto en este caso mpeg3-utils
    ya que lo posee también el cinelerra y ya está

    ResponderEliminar
  31. He seguido tu tutorial y no he conseguido que me funcione Cinelerra.
    Y ahora al tratar de actualizar el Gutsy
    con
    sudo apt-get install -f
    resulta que no puedo porque ... me sale todo esto:
    xanti@xanti-desktop:~$ sudo apt-get install -f
    [sudo] password for xanti:
    Leyendo lista de paquetes... Hecho
    Creando árbol de dependencias
    Leyendo la información de estado... Hecho
    Se instalaron de forma automática los siguientes paquetes y ya no son necesarios.
    libunshield0 libxine1-gnome
    Utilice «apt-get autoremove» para eliminarlos.
    Los siguientes paquetes se ELIMINARÁN:
    cinelerra-generic
    0 actualizados, 0 se instalarán, 1 para eliminar y 13 no actualizados.
    1 no instalados del todo o eliminados.
    Necesito descargar 0B de archivos.
    Se liberarán 23,2MB después de desempaquetar.
    ¿Desea continuar [S/n]? S
    (Leyendo la base de datos ...
    244741 ficheros y directorios instalados actualmente.)
    Desinstalando cinelerra-generic ...
    Description: Ubuntu 7.10
    locale "es_ES.ISO-8859-15" not in archive
    rm: no se puede borrar `/usr/bin/Cinelerra': No existe el fichero ó directorio
    dpkg: error al procesar cinelerra-generic (--remove):
    el subproceso post-removal script devolvió el código de salida de error 1
    Se encontraron errores al procesar:
    cinelerra-generic
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    ¿Me podrías ayudar a resolverlo?
    No me permite actualizar ningún archivo.
    Cuando trato de hacerlo con el synaptic:
    E: cinelerra-generic: el subproceso post-removal script devolvió el código de salida de error 1

    Gracias por tu ayuda.

    ResponderEliminar
  32. Veo que te sale un problema de locales has efectuado el comando?:
    sudo dpkg-reconfigure locales
    porque lo que te dice es que no lo tienes en el archivo. Por otro lado parece que el archivo cinelerra ya lo has borrado ya que te dice que no lo encuentra, por eso te da el error. De todas maneras me extraña que solo te quiera eliminar un paquete cuando de cinelerra depende otros como libmpeg y algún otro. Como empezaste a desinstalar los archivos de cinelerra? Así sin más datos sólo te puedo indicar que intentes reinstalarlo para posteriormente eliminarlo. Mira a ver si te funciona con el metodo 2 que desde el principio a mi me fue bien

    ResponderEliminar
  33. El manual mas completo que he encontrado.
    Lo enlazo a mi blog :P

    ResponderEliminar
  34. Gracias por el tutorial, a mi lo que me sirvio mucho fue la castellanización, aún estoy aprendiendo a maniobrarlo, estoy en busca de efectos para imagenes fijas.... para crear algo as icomo pase de diapositivas con audio...
    Gracias por el aporte

    Luumil

    ResponderEliminar
  35. hola,
    llegué a este hilo después de tener ya instalado cinelerra buscando de qué modo podía castellanizarlo. Seguí todos vuestros pasos y no había manera, ni modificanco las locales ni nada de nada.
    Esta mañana por fin he visto la luz, después de hacer todo lo indicado por vosotros, lo único que me faltaba era ejecutar cinelerra DESDE CONSOLA.
    después de hacer el export LANG=es_ES
    si lo ejecutaba desde el menú de aplicaciones me salía en ingles y si lo hacia desde consola me salia en castellano.

    Total que no le tengo mania ni nada a la consola, pero como me resulta más cómodo ejecutar los programas desde los iconos del cuadro y éstos no són más que accesos directos a los iconos del menú de aplicaciones, para que se ejecute cinelerra en castellano mediante iconos he hecho lo siguiente:

    - crear un script con el siguiente texto:
    #!/bin/sh
    export LANG=es_ES
    cinelerra
    - guardarlo. P.ex: /home/usuario/cinelerraCastellano
    - moverlo a opt/cinelerra/
    sudo mv /home/usuario/cinelerraCastellano /opt/cinelerra/cinelerraCastellano
    - darle permisos de ejecución
    sudo chmod 722 /opt/cinelerra/cinelerraCastellano
    - ahora para que el icono de aplicaciones/sonido y video/cinelerra apunte al script en vez de al programa directamente modifico el archivo cinelerra.desktop
    sudo gedit /usr/share/applications/cinelerra.desktop

    modifico la línea Exec para que apunte al script:
    [Desktop Entry]
    Name=Cinelerra
    Name[ja]=Cinelerra
    Name[sl]=Cinelerra
    Name[fr]=Cinelerra
    Name[es]=Cinelerra
    Comment=Video Editor
    Categories=Application;AudioVideo;Multimedia;
    Encoding=UTF-8
    Exec=/opt/cinelerra/cinelerraCastellano
    Icon=cinelerra.xpm
    Terminal=false
    Type=Application

    - guardo
    - reinicio
    VOILÀ!! ya se abre siempre en castellano.

    un saludo

    ResponderEliminar
  36. ops, perdonad que no os he dicho que lo hecho es en ubuntu 8.10

    un saludo de nuevo y gracias por el hilo

    ResponderEliminar
  37. Anónimo6:07 a. m.

    Besten Dank. levitra 20mg preis levitra nebenwirkungen [url=http//t7-isis.org]cialis rezeptfrei[/url]

    ResponderEliminar